Tutoriel : installer une PirateBox en images

Ce tutoriel présente l’installation et la configuration d’une PirateBox, le dispositif de partage numérique libre, anonyme et gratuit. L’installation d’une PirateBox n’est pas si facile pour les non initiés, l’idée est donc d’illustrer le tuto afin de rendre l’installation de la PirateBox plus simple. Prévoyez environ 1h pour monter votre PirateBox de A à Z.

Ce tutoriel est basé sur le tuto de David Darts, le créateur de PirateBox.

Prérequis

Voici la liste du matériel et des pré requis :

  • TP-Link MR3020 (ici ou )
  • Clé USB (formatée en FAT32, n’importe quelle taille, plus y’en a, plus on en met ;))
  • Câble ethernet (fourni avec le MR3020)
  • Câble USB pour l’alimentation (fourni avec le MR3020)
  • Connexion Internet (uniquement nécessaire pour l’installation de la pirate box)
  • Batterie USB (si vous souhaitez balader votre PirateBox)
TP-Link MR3020

Déballage du TP-Link MR3020

Préparation du routeur MR3020 de TP Link

1. Mettre le MR3020 en mode WISP

Le bouton se situe sur le routeur. Il y a 3 modes : 3G, WISP et AP.
Pour info WISP c’est : Wireless Information Service Point ou Wireless Internet Service Provider, selon l’utilisation.

2. Connecter le MR3020 à votre ordinateur par câble réseau

Le MR3020 doit être sous tension (LED verte allumée), donc connecté à l’aide du câble mini USB à une source d’énergie (port USB de votre ordinateur ou adaptateur secteur fourni).

Connecter le MR3020 à votre ordinateur grâce au câble réseau (RJ45), attendez quelques secondes pour que votre ordinateur reconnaisse le périphérique et ouvrez votre navigateur sur la page http://192.168.0.254/ (identifiant : admin ; mot de passe : admin)
Vous êtes maintenant connecté à l’interface de configuration du routeur.

Connecter le MR3020 à l’ordinateur via câble réseau

3. Mettre à jour le firmware du MR3020

Télécharger le Firmware OpenWRT pour MR3020.
Naviguer vers System Tools > Firmware Upgrade sur l’interface d’admin du MR3020
Uploader le nouveau firmware grâce au formulaire prévu à cet effet

Après la mise à jour, le MR3020 va redémarrer.

4. Configurer le réseau du MR3020

En telnet, connectez-vous à l’adresse 192.168.1.1
Vous aurez peut être besoin d’activer telnet sous Windows 7 si ce n’est pas déjà fait.

Pour vous connecter via telnet :

Démarrer > Exécuter… > Tapez cmd (une fenêtre noire s’affiche)
puis C:\> telnet 192.168.1.1

Vous êtes maintenant connecté au MR3020 via telnet.

Tapez passwd pour changer le mot de passe.

passwd

Vous devez saisir le nouveau mot de passe 2 fois (attention, les caractères saisis n’apparaîtront pas à l’écran).

Nous allons maintenant éditer la configuration du réseau. Pour cela, munissez-vous des 2 informations suivantes :

  • l’adresse IP de votre routeur (ie : l’adresse de votre box). Exemple : 192.168.1.254
  • une adresse IP arbitraire appartenant au réseau. Exemple : 192.168.1.55

Editer le fichier de configuration du réseau (/etc/config/network).
Tapez :

vi /etc/config/network

Le fichier doit ressembler à ça :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.55
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.254
list dns ‘192.168.1.254
list dns ‘8.8.8.8’

Enregistrez, pour cela tapez :

[Echap]:wq[Entrée]

Cela enregistrera le fichier /etc/config/network et quittera l’éditeur vi.
En tapant la commande vi, vous ouvrez un éditeur de texte (si, si).
Tapez sur i ou touche Inser pour insérer du texte. Naviguer dans le texte à l’aide des flèches de votre clavier.

5. Configurer le pare-feu du MR3020

On va maintenant modifier le pare-feu du routeur MR3020. Pour cela, on modifie le fichier /etc/config/firewall.
Avant tout, on fait une copie de sauvegarde :

cp /etc/config/firewall /etc/config/firewall.bak

On édite le fichier /etc/config/firewall (comme tout à l’heure on utilise vi)

vi /etc/config/firewall

On appuie de nouveau sur i ou Inser pour passer en mode insertion et on modifie le fichier pour qu’il ressemble à ça (seules les 23 premières lignes sont modifiées) :

config defaults
option syn_flood ‘1’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name ‘lan’
option network ‘lan’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’

config zone
option name ‘wan’
option network ‘wan’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’
option masq ‘1’
option mtu_fix ‘1’

On enregistre et on quitte l’éditeur :

[Echap]:wq[Entrée]

6. Activer le Wifi du MR3020

On commence à avoir l’habitude, on modifie le fichier /etc/config/wireless :

vi /etc/config/wireless

Et on change la ligne 12 pour qu’elle ressemble à ça :

option disabled 0

Puis tapez :

[Echap]:wq[Entrée]

Le Wifi sera activé au prochain démarrage.

Débrancher le routeur de sa source d’énergie (mini USB).

La configuration est maintenant terminée ! On va maintenant passer à l’installation de la PirateBox sur le routeur MR3020. 🙂

Installation de l’application PirateBox

Pour installer PirateBox, il va nous falloir une connexion Internet.
On va donc reconnecter notre routeur MR3020 à notre box Internet.

Connectez le MR3020 directement à votre box Internet grâce au câble réseau. Dans mon cas, c’est une Bbox.

Le MR3020 est connecté à la box

Mettre le MR3020 sous tension en le connectant à l’aide du câble mini USB (ici connecté à mon PC).

1. Ajouter la compatibilité USB au routeur

Connectez-vous en SSH au routeur MR3020. Pour cela, vous aurez besoin de Putty (télécharger Putty ou voir le site).

Connectez-vous via Putty à l’adresse définie à l’étape 4 (ici 192.168.1.55).

En nom d’utilisateur, mot de passe, tapez :

login as: root
root@192.168.1.1’s password : [le mot de passe saisi plus haut lors du passwd – étape 4]

Attention, les caractères du mot de passe ne s’afficheront pas.

Accueil du MR3020 après connexion SSH via Putty

Assurez-vous que la connexion Internet est bien active.

ping google.com

Si ce n’est pas le cas, quelque chose ne va pas dans la configuration du routeur. Je vous conseille de vérifier les informations de configuration du routeur, notamment les adresses IP du réseau.

Ajouter le support USB en tapant les commandes suivantes :

opkg update
opkg install kmod-usb-uhci
insmod usbcore
insmod uhci
opkg install kmod-usb-ohci
insmod usb-ohci

En cas d’erreur, continuez quand même !
Une fois toutes les commandes exécutées, le MR3020 a été mis à jour pour prendre en charge une clef USB. Cool 🙂

2. Connectez votre clef USB.

Elle doit être formattée en FAT32. Pour le savoir, connectez votre clef à un port USB de votre ordinateur, clic droit sur le lecteur puis Propriétés. Voir Système de fichiers = FAT32 sous Windows 7.

3. Installer PirateBox

Dans la fenêtre SSH toujours ouverte, tapez :

cd /tmp
wget http://piratebox.aod-rpg.de/piratebox_0.3-2_all.ipk
opkg update && opkg install piratebox*

Pour info, vous pouvez installer la version sans le chat en tapant ces commandes à la place :

cd /tmp
wget http://cr.23bit.net/piratebox/piratebox_0.2-5_all.ipk
opkg update && opkg install piratebox*

L’installation peut prendre du temps. Soyez patient !

L’installation de la PirateBox est terminée !

Débrancher le câble réseau que vous pouvez ranger et éteignez le MR3020 complètement.

Attendez quelques secondes, le temps qu’il se repose, puis redémarrer le.

4. Vous êtes l’heureux propriétaire d’une PirateBox fonctionnelle

Vous ou n’importe qui peut désormais se connecter au réseau « PirateBox – Share Freely » avec n’importe quel appareil possédant une carte Wifi.
En ouvrant votre navigateur, vous devriez tomber sur cette page :

accueil piratebox

La page d’accueil piratebox

Tout le traffic est routé vers cette page, donc peu importe l’URL que vous taperez, vous serez rediriger vers cette page. 😉

Problème : ma PirateBox lente avec la version chat shoutbox (3.2)

Si votre PirateBox est lente avec la shoutbox (chat), modifier le fichier /etc/config/network comme ceci :

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option proto ‘static’

Source

Mettre à jour sa PirateBox en version 0.5.1

Suite à cette installation, vous pouvez mettre à jour votre PirateBox en version 0.5.1. Je vous invite à découvrir le tuto de mise à jour en PB 0.5.1.
Il est également possible de remplacer l’étape d’installation de la PirateBox de ce tuto par l’action 7 du tuto de mise à jour.

Matos : routeurs Wifi

  • CORRINA OLSON

    Good article, Thanks!

  • Shona Nora

    my colleague was requiring DA 3349 earlier this week and was informed of a great service that hosts a lot of sample forms . If people want DA 3349 as well , here’s a https://goo.gl/vl6oH5

  • flash

    salut, le lien vers le firmware est mort 😉

  • Rivo

    Serait-il possible d’utiliser d’autres routeurs wifi que le MR3020?

  • Greg

    Bonjour,
    Après être arrivé à la partie : Activer le Wifi du MR3020, je n’arrive plus à utiliser la wifi du routeur, en effet plus de LED allumé pour le wifi.
    Ensuite, je ne peut pas me connecter en SSH..
    Merci de votre aide.

  • Greg

    Bonsoir,
    J’ai un problème à partir de : Activer le Wifi du MR3020, en effet à partir de ça, ( après avoir changé « option disabled 0 » du fichier Wireless ), la wifi ne s’allume plus. Ensuite je n’arrive plus à me connecté en SSH.
    Merci de votre aide.

  • Fiskh

    Bonjour.

    J’ai un soucis lors de l’étape 3, installation de la pirate box. une fois dans cd /tmp, j’entre la commande wget http://cr.23bit.net/piratebox/piratebox_0.2-5_all.ipkopkg update && opkg install piratebox*, la première étape se passe bien mais ensuite, pas moyen d’update (avec le message d’erreur suivant : opkg_download: failed top download http://stable/openwrt.piratebox.de/ar71xx/packages/Packages.gz, wget retruned1.

    Quelle serait la marche à suivre afin de réussir ce donwload?

    D’avance merci.

  • Damien T

    Salut à tous,

    Tout d’abord, super tuto, très clair, bien construit, rien à redire.

    Cependant, j’ai un soucis lors du paramétrage du modem (MdP, config IP, activer le wifi, …)
    J’effectue les modifications, je vérifie qu’elle soient bien prises en compte, tout est bon.
    Mais lorsque je débranche éléctriquement le modem MR-3020 pour le rebrancher, il n’a plus aucune modifications que j’ai fait, à commencer par le mot de passe.

    J’aurai aimé un petit coup de pouce.

    Merci d’avance !

  • Bon j’ai manqué de patience il semblerait. Cependant est-il normal que l’installation de ces paquets via opkg prenne autant de temps ?

  • Bonjour,

    Chez moi aussi l’installation du paquet python-mini_2.7.3-1_ar71xx.ipk bloque. Cela doit faire 30 minutes qu’il est bloqué dessus.
    J’ai refais toute l »installation deux fois, après un reset. Toujours le même problème.
    Quelqu’un a une idée ? Quelqu’un d’autre a tenté l’expérience ces jours-ci ?

  • Baptiste

    Bonjour,
    Merci beaucoup pour ce tuto sauf que je bloque depuis quelques heures sur un os. Lorsque je fais #opkg update il me donne cette erreur « Failed to download ».
    La requête ping sur google fonctionne très bien. J’ai essayé en continuant le tuto mais ça bloque lors de l’installation de python lors de l’install de piratebox.
    J’ai essayé avec ton fichier de conf pour network mais aussi avec un autre il me met toujours la même erreur.

    Merci d’avance pour votre aide!

  • Quentin

    bonjour, j’aurais besoin d’aide, je n’arrive pas à avancer après me connecter à putty, j’ai compris au bout de 3/4 d’heure que je m’étais planté dans les adresses ip programmer dans /etc/config/network et tout mais bon, j’ai tout modifier et j’arrive à me connecter maintenant à mon MR-3020 qui est sur la free, je croyais le problème résolu mais…
    Quand je ping google, bad adresse, et tous tests de ping de site internet donnent le même résultat, pourtant le MR-3020 est sur le réseaux puisque lorsque je le ping tout va bien…

    Je comprends pas pourquoi il n’y a pas d’accès internet, aurais-je mal fait un truc:

    config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config interface ‘lan’
    option ifname ‘eth0’
    option type ‘bridge’
    option proto ‘static’
    option ipaddr ‘192.168.0.55’
    option netmask ‘255.255.255.0’
    option gateway ‘82.232.134.177’
    list dns ‘82.232.134.177’
    list dns ‘8.8.8.8’

    • Quentin

      c’est bon j’ai réussit à régler le problème en bidouillant les adresses ip, j’ai essayé quelque truc et j’ai réussit 😀

      • Jeremie

        Salut Quentin,
        J’ai le même probléme que toi avec le ping (bad adress)!!!!
        Je ne comprends pas pourquoi ça ne fonctionne pas…?
        Quest ce que tu as modifié dans tes adresses IP?

        Merci

  • toubi

    bonjour

    j’ai un problème sur telnet mais lors de ma connexion sur mon tp-link avec telenet j’ai ce message d’erreur impossible d’ouvrir un connexion à l’hote, sur le port 23: echec de la connexion

    • Gonzague DUCOS

      Bonjour,

      Je tente un « up » un peu en désespoirs de cause, car je n’arrive pas à trouver la solution. J’ai aussi un tp-link avec le même message de telnet : impossible d’ouvrir un connexion à l’hôte, sur le port 23 : échec de la connexion. C’est donc à l’étape 3 que ça bloque, la MAJ du firmware s’étend bien passé. Quelqu’un saurait-il d’où pourrait venir le problème ? Merci !

      • Bonjour,

        quelles adresses avez-vous tester ?

        telnet 192.168.0.1
        telnet 192.168.0.254
        telnet 192.168.1.1
        telnet 192.168.1.254
        
  • tuxi

    Bonjour,

    Je voudrais acquerrir 2 routeurs MR3020 pour une utilisation Lan mais je ne sais pas si ils auront les meme mac adresses ?
    est-ce que vous pouvez me dire si les mac adresses sont identiques pour tous les routeur mr3020 ? , par exemple la mienne se termine par :FC

    • Bonjour,

      les adresses MAC sont forcément différentes (mais facilement modifiables). Pour les adresse IP, vous pouvez les spécifier dans la configuration du routeur.

  • tuxmouraille

    Bonjour,
    eodane a raison c’est l’adresse qui a été configuré dans /etc/config/network qui faut utiliser pour ce connecter au routeur et pas 192.168.1.1 qui est dans l’exemple pris: une Bbox, l’adresse de la Bbox.

  • gilles

    Bonjour ,jje n’arrive pas à reset usine le routeur . lorsque je tape la commande
    rm -rf /overlay/* il me dit acces denied .

  • agui

    bonjours je vien de commencer le tuto mais c est bizarre,quand je clique a http://192.168.0.254/ a l étape 2 sa me revoie sur la page « accueil freebox serveur »!!!quelqu un a t il une idée du pourquoi?
    merci

  • Julien

    Bonjour, J’ai raté mon étape 4, je ne parviens à me connecter ni en telnet (normal) ni en SSH ( je ne sais pas ce que j’ai mis comme adresse IP) Que puis-je faire ? Je suis sur mac, par contre mais ce n’est pas bien différent. j’uilise le terminal pour le telnet et le SSH

    • Bonjour,

      Pour trouver l’ip fait un ipconfig /all (commande Windows, trouve l’équivalent Mac).

      Si ça ne fonctionne pas, regarde dans les commentaires précédents, il y est marqué comment faire un reset du tp-link.

  • eodane

    Hello,

    Piratebox fonctionnelle, cependant il y a une petite erreur dans le tuto faisant qu’un noob comme moi se retrouve bloqué le temps de comprendre.

    Chapitre « Installation de l’application piratebox »
    « 1. Ajouter la compatibilité usb au routeur »
    « connectez vous via putty a l’adresse 192.168.1.1 »

    A mon sens ce n’est pas cette adresse la qu’il faut mettre mais celle inscrite dans /etc/config/network a la ligne option ipaddr, non ?

    Parce qu’a cette étape si j’essaie via putty de me connecter au 192.168.1.1 ca ne marche pas du tout, alors que via l’adresse renseignée ca marche.

    Ne vous foutez pas de ma gueule tout de suite hein ^^ je débute 🙂

    Autre question, une fois la config faite, est il possible de remplacer la clé usb pour une plus grosse ?
    si oui, je suppose qu’il faut eteindre le routeur, changer la clé et le redémarrer ?

    Merci de vos aides 🙂

  • peter

    Impossible de le configurer, le ping google ne donne jamais rien. Ma box semble ne pas lui attribuer d’ip: 0.0.0.0 via mon ordinateur de bureau et pourtant, open wrt est un réseau reconnu par mon portable en wi-fi et qui me permet d’accéder au net…je suis perdu

    • Dash

      Poste /config/network.

  • Dash

    Regarde : http://forum.daviddarts.com/read.php?2,3349 et suivre la procédure du post 673 (Matthias)

  • Flagdidou

    Bonjour,
    J’ai suivi la procedure jusqu’à l’install de la piratebox avec les commandes
    « # cd /tmp
    # wget http://pirtaebox.aod-rpg.de/piratebox_0.3-2_all.ipk
    # opkg install piratebox*  »
    mais ma clé USB n’est pas reconnue, j’ai fait les manip du style prendre une autre clé, formater en rapide et lent,etc, y aurait-il un endroit où trouver une réponse à mon problème, j’ai trainé un peu partout mais je désespère…
    Par avance merci…

  • Dash

    <un p'tit lien sur la francisation de la PB http://forum.daviddarts.com/read.php?2,2787

  • Koneko

    Je suis au bord de jeter l’éponge… Je m’explique :
    MR3020. j’arrive après des heures de lutte à installer le tout. Sauf que l’affichage de la page d’accueil est carrément super long. Depuis mon smartphone, je n’y accède même pas. (et depuis mon pc, faut prendre son mal en patience) Une fois péniblement chargée, je tente un dl : 549mo en 6min et 37 secondes. Je trouve ça plutôt raisonnable.
    Mais cette longueur me chagrine. Je décide de repartir de zéro et donc de réinstaller le firmware d’origine. Je fais un reset (celui de votre autre billet) et ensuite logique, on ne peut plus ping google (par ex), alors dl le firmware je ne sais pas comment je peux faire…
    Bref, je dois me vautrer quelque part, mais j’ai tellement le nez dessus que je ne vois pas.
    Craquage.
    Y aurait-il une bonne âme pour m’aider ?

    • Koneko

      nevermind, je me suis débrouillée… tout fonctionne ! o/
      et sinon, merci pour votre tuto !

  • stanlog

    Bonjour,
    Concernant l’erreur « package not found » lors de l’installation de kmod-usb-storage, un ticket a été ouvert sur le bugtracker. Pour l’erreur lors de l’install de kmod-usb-uhci, c’est le même problème. J’espère que les devs OpenWRT vont faire le nécessaire rapidement, car sans doute comme certains d’entre vous, je suis un peu bloqué pour la suite…

    N’hésitez pas à faire remonter l’info. quand ces 2 paquets seront disponibles dans les snapshots. ++

    • stanlog

      Je me réponds : la solution est . Enjoy !

      • Dash

        L’info était déjà là.

        • stanlog

          Oups, j’avais zappé, j’étais focalisé sur le fait d’utiliser le dernier snapshot factory. Désolé 🙁 Sinon, pour ceux qui auraient des soucis de lenteur, pensez à virer les dns et gateway dans le fichier /etc/config/network. J’ai eu le problème, et ce n’était que cela.

          Merci pour ce tuto. et pour les infos dans ces commentaires.

          • Dash

            Bon à savoir, merci 😉

          • Merci pour toutes ces infos. Je vais faire une petite compilation des commentaires et mettre à jour l’article.

  • adrien

    Bonjour,

    J’ai un gros soucis lors de l’étape de la connexion SSH. Je n’y arrive tout simplement pas !
    J’ai portant suivi le tuto de David Darts, mais impossible de se connecter ><
    Je me suis dit "bon ba je réinitialise et je recommence". Eh bien non, je n'arrive pas non plus à me connecter en SSH pour réinitialiser (je précise que j'ai déjà installer OpenWRT).
    Y a t-il une solution ?

    PS : je suis sous MacOSX snow Leopard, mon router est une Freebox Revolution et j'utilise la config suivante

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.111'
    option netmask '255.255.255.0'
    option gateway '192.168.2.1'
    list dns '192.168.2.1'
    list dns '8.8.8.8'

    Merci d'avance

    Adrien

    • Guillaume

      Rien a voir avec ta freebox.
      Quel est le probleme en fait ? Quel est le message d’erreur ?
      Sur mac, tappe ssh root@192.168.1.1

      • adrien

        Alors j’ai un message d’erreur :
        « ssh: connect to host 192.168.1.1 port 22:Operation time out »
        Voici un screen de l’erreur :
        Erreur

      • adrien

        Bonsoir,
        Le message d’erreur est le suivant :
        « ssh: connect to host 192.168.1.1 port 22 : Operation time out »
        Au cas où j’ai un screen 😉

        • adrien

          Erf fail désolé pour le double post :s

        • Guillaume

          C’est bien un probleme de connexion, un probleme reseau, mais cela ne doit venir de ta freebox, pour le moment tu dois pouvoir te connecter en ssh avec le cable reseau, sans la connecter a la freebox. Pour cela il faut que l’ip de la pb et l’ip de ton mac soit dans le meme reseau, ex 192.168.1.x et 192.168.1.y

          • Dash

            et avec le câble réseau en ssh au192.168.2.111?

          • Guillaume

            Non, prend les ip que j’ai indiqué en mettant x=1 pour la pb de preference et y= ce que tu veux pour ton mac

          • Dash

            Il a choisi dans sa config network de mettre 192.168.2.111 comme ip pour le 3020.

          • adrien

            Ca marche en ssh en câblé sur 192.168.2.111
            =)

          • Dash

            Y a plus cas poursuivre l’installation!

    • adrien

      Re-bonjour

      Alors maintenant j’ai un problème avec l’installation du support USB. J’obtient le message suivant :
      root@OpenWrt:/tmp# opkg install kmod-usb-uhci
      Unknown package ‘kmod-usb-uhci’.
      Collected errors:
      * opkg_install_cmd: Cannot install package kmod-usb-uhci.

      Et du coup impossible d’installer la Pirate box :
      Collected errors:
      * satisfy_dependencies_for: Cannot satisfy the following dependencies for piratebox:
      * kmod-usb-storage *
      * opkg_install_cmd: Cannot install package piratebox.
      J’ai regardé sur les forum (http://forum.daviddarts.com/read.php?2,3189,3194#msg-3194) mais rien en marche.
      Une idée ?

      • dvalin33

        Bonjour,

        J’ai le même problème, aucun conseil du forum n’a arrangé ce problème. J’espère que ca va s’arranger rapidement.

      • adrien

        Bon j’ai viré la plupart des erreurs. Et j’ai trouvé d’où vient le problème : impossible d’installer kmod-usb-storage.
        Y a t-il un autre moyen de la faire que opkg install ?

      • Dash

        Le ping Google donne quoi?

        • adrien

          Il est bon, j’ai installer les pkg ohci, ubs2 et télécharger la version 2.5 de piratebox. Quand j’eesaye d’installer kmod-usb-storage il me retourne de message suivant :
          root@OpenWrt:/tmp# opkg install kmod-usb-storage
          Unknown package ‘kmod-usb-storage’.
          Collected errors:
          * opkg_install_cmd: Cannot install package kmod-usb-storage.

          • adrien

            Ah ah je vois d’où vient le bug ^^
            Le package n’existe plus : http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/
            (chercher à kmod-usb)
            Quelqu’un à un lien valide vers le package ?

          • Dash

            Comprends pas pk tu lances la commande kmod-usb storage.

          • adrien

            Bah apparemment pour s’installer pirtatebox demande ce package :

            root@OpenWrt:/tmp# opkg update && opkg install piratebox*
            Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
            Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
            Updated list of available packages in /var/opkg-lists/snapshots.
            Installing piratebox (0.2-5) to root…
            Collected errors:
            * satisfy_dependencies_for: Cannot satisfy the following dependencies for piratebox:
            * kmod-usb-storage *

            * opkg_install_cmd: Cannot install package piratebox.

            Et en regardant dans /var/opkg-lists/snapshots on voit effectivement que kmod-usb-storage n’existe pas :s

          • Dash

            Tu avais essayé:
            opkg update && opkg install kernel
            et recommencé l’installation de l’Usb?

            C’est toi le message sur le forum openWrt ?:)

          • adrien

            Ouais le kernel est mis à jour 😉
            Et pour répondre à la question précédente, il semblerait que pour installer piratebox, le package kmob-usb-storage est nécessaire. En fouinant un peu dans http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/ je me suis rendu compte que ce que je cherche n’est plus disponible :s
            En allant sur le fofo de OpenWRT (https://forum.openwrt.org/viewtopic.php?pid=165276) j’ai cru comprendre que les package sont en train d’être mis à jour, et que le seul truc à faire c’est d’attendre…

            PS : non ce n’est pas moi qui suis aller poster là bas ^^

          • Dash

            Sur le forum openWrt du 3020, il y a un « Andre »qui posait la question au sujet de l’usb storage aujourd’hui…;)
            Dommage pour la mise à jour du kernel…ça m’a permis de supprimer les messages d’erreur lors de l’installation de l’usb. A ce stade, soit tu tentes la réinstallation du firmware d’origine pour une nouvelle installation (voir tuto bas de page http://wiki.openwrt.org/toh/tp-link/tl-mr3020 après reset du 3020 http://blog.nicolashachet.com/2012/04/05/fonctionnement-du-web/reset-du-mr3020/ ) soit on suit les MAJ sur les forums OpenWrt et Daviddarts

          • Dash

            Du nouveau: http://forum.daviddarts.com/read.php?2,3349
            (post de Mattthias qui propose l’installation de son image). Des retours?

          • Adrien

            HELL YEAH
            Ca fonctionne ^^
            Par contre le version 3.2 est super lente, je vais réinitialiser et test la version 2.5.
            Et tout cas merci !

          • Dash

            Cool! Tu pourrais détailler ?

          • Adrien

            Bien sûr !
            Alors premièrement il faut mettre à jour la version du firmware avec celle donnée par matthias.

            Une fois connecté en ssh à ton router tu fais

            cd /etc/tmp
            wget http://piratebox.aod-rpg.de/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
            mtd write openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin firmware
            reboot

            Ton router redémarre et ensuite il faut faire un telnet 192.168.1.1 (je suis resté branché à ma box). Une fois l’accès au router établi tu change le mdp (passwd) et tu édite le fichier /etc/config/network avec la config du tuto.

            Une fois cela fait, tu te connecte à ton MR3020 par ssh (ssh root@192.168.1.1) et tu exécute la commande /etc/init.d/network reload
            Un petit edit de /etc/config/firewall et /etc/config/wireless (comme vu dans le tuto)
            Ensuite un petit test de connexion (ping google.com), tu bouge dans /etc/tmp et tu fais :

            wget http://cr.23bit.net/piratebox/piratebox_0.2-5_all.ipk
            opkg install piratebox*

            Et normalement c’est tout bon ^^

          • Dash

            Merci pour le détail Adrien. Ca va surement en aider plus d’un!

  • Dash

    Re…non ce n’est pas une tentative de flood des commentaires 🙂 j’ai exactement le même problème que Sylvain (10 avril) et DValin33 lors de l’installation de l’USB. Impossible d’aller plus loin. Avez vous réussi à solutioner le problème (réinstallation après reset du routeur, DL d’un autre pilote USB, lancé du 3020 du 5ème étage…) ?
    Merci pour le coup de main.

    • Guillaume

      Bonjour,
      Je te conseille d’aller voir le forum de David Darts(http://forum.daviddarts.com/), et lancer la recherche sur « Cannot satisfy the following dependencies for kmod-usb-ohci ».

      Il y a plusieurs posts, mais visiblement dans le premier un mec a une solution. J’espère que tu maitrises un peu l’anglais.

      • Dash

        Merci pour l’info Guillaume. Ca a réglé mon message d’erreur et je suis allé au bout sauf qu’il ne semble pas reconnaitre la clé USB.
        Message : « please connect USB drive »…………………(j’ai essayé plusieurs clés, formatées correctement, rien n’y fait. Une des clé a une diode rouge qui ne s’allume même pas. J’ai essayé également avec un disque dur portable qui lui s’allume mais ça ne change rien).
        Est ce que je ne me serais pas planté dans la config/network ?
        Ma config sous LiveBox Sagem (192.168.1.1 pour accéder aux paramètres):
        -adresse Ipv4 : 192.168.1.11
        -masque sous réseau : 255.255.255.0
        -passerelle par défaut : 192.168.1.1
        -serveur DNS : 192.168.1.1
        Ma config Network:
        option ipaddr ‘192.168.1.13’
        option netmask ‘255.255.255.0’
        option gateway ‘192.168.1.1’
        list dns ‘192.168.1.1’

        Lorsque je me connecte donc en ssh à 192.168.1.13 toute la procédure se déroule normalement sauf ce fichu message à la fin…

        • dvalin33

          @Dash : quelle est la manip que tu as fait pour passer le message d’erreur ? Perso, ça m’intéresserait (vu que je comptais le faire ce soir).

          Quelle est la taille des clefs usb que tu utilise ?

          • Dash

            Salut Dvalin,
            la procédure ici—–>http://forum.daviddarts.com/read.php?2,3189,3194#msg-3194 (2ème post de Matthias puis dernier post de gRou$e, pour le même résultat. Malheureusement la discussion s’arrête là).

            Pour les clés: 4Go et 16 Go formatées FAT32 (formatage rapide puis normal).

        • Guillaume

          J’ai pas bien tout compris tes histoires d’adresses IP. Ta piratebox doit être en 192.168.1.1. Ta Livebox est en 192.168.1.11 et a comme passerelle 192.168.1.1.
          D’où elle sort cette IP 192.168.1.1 ? T’as un autre routeur que ta Livebox ?
          Seule ta Piratebox doit avoir 192.168.1.1, et ce pendant l’installation, car après elle ne sera plus connectée au réseau.

          Mais de toute façon je vois pas le rapport avec l’USB. A mon avis, tu as peut être réussi à faire l’installe du package USB, mais visiblement ça ne s’est pas super bien fait…

          Ta clef doit être formatée en FAT32 (et non FAT16), et d’après quelques commentaires ne devrait pas dépasser les 16Go (à vérifier).

          • Dash

            Bon ben là je sèche…

          • Guillaume

            @ Dash
            Argg. On va y arriver bon sang de bon sang !
            Y’a une autre possibilité : tout refaire. On peut même remettre le software TP-Link s’il faut.

            Mais comme çà, là à distance… c’est pas simple… En plus t’as du faire tellement de chose qu’on sait plus où tu en es…
            Tu serais pas sur Paris par hasard ?

          • Dash

            @Guillaume : non, je ne suis pas sur Paris…bien dommage! Je me suis résolu à suivre le lien (http://wiki.openwrt.org/toh/tp-link/tl-mr3020) d’un des commentaires sur le tuto « reset rm3020 ». Je suis revenu au firmware TP-link 3.12.11 Build. Avant de redémarrer l’installation, 2 questions:
            -dans les statuts, j’ai « Wan port is not connected » : soucis?
            -y a moyen à ce stade de savoir si le port USB n’est physiquement mort?
            Merci pour ta patience…

          • Guillaume

            Que tu ais réussi a faire un reset usine est déjà une bonne nouvelle. Il n’était pas certain que le bin soit le bon, mais a priori c’est le cas.

            Y’a peu de chance que le port usb soit mort, a moins que tu soit du genre maudit…

            Où est-ce que tu vois ce status du Wan ?

            Quand t’auras bien connecté ton MR3020 a ta livebox, vérifie la connection a coup de ping ou traceroute.

            Ensuite suit bien la procédure.

            Tu es sous Windows ? Si non, en ssh fait bien attention de faire ssh root@192.168.1.1 sans oublier le root@ sinon il va prendre ton login linux ou mac. Sur Putty je ne sais pas.

          • Dash

            Bon, ça fonctionne. Ce qui m’embête c’est de ne pas comprendre ce qui a pu se passer…Je vous livre ma « cuisine »:
            réinstall du frimeware TP-Link d’origine (bas de page http://wiki.openwrt.org/toh/tp-link/tl-mr3020). Reboot du TP-Link. Connection en ethernet à l’interface admin. Cle USB enfoncée et retirée plusieurs fois du 3020 (le led de la clé s’est enfin allumé); installation (cf tuto). Grosse connerie(?) j’ai fait cette nouvelle installation sur la cle qui contenait déjà les fichiers de l’install piratebox usb live (faite dans l’après-midi et que j’ai oublié d’effacer)…

          • Sylvain

            Bonjour

            Pour ma par j’ai rien eu le temps de faire….

            Mais puisque d’autre on essaille je vais profiter de leur expérience.
            En gros il repartir de zéro ?

            A quel moment tu teste le clés pour savoir si ça marche ?

          • Dash

            Bonjour,
            lorsque le firmware TP-Link a été réinstallé et que tu es loggué sur la page d’administration avec l’IP 192.168.0.254 (étape 2 du tuto).

  • Dash

    Oups, il manquait effectivement l’espace après « vi »…..désolé ! et merci tout le monde (j’y suis depuis de début de l’après-midi)

  • Dash

    Bonjour à tous.
    J’ai un (gros) petit problème juste après la mise à jour du firmware.
    Une fois Putty lancé vers 192.168.1.1 et rentré les identifiants, la commande :-vi/etc/config/network me renvoie : « not found »
    Idem pour la commande : vi/etc/config/firewall
    La commande :
    /etc/config/firewall :permission denied

    Est ce la mise à jour du 3020 qui a merdé?
    Toutes les pistes & idées seront les bienvenues…
    Merci d’avance

    • dvalin33

      Bonjour,

      Dash, comment te connectes tu ? Telnet, ssh, autre ? J’ai eu le même problème mais je m’étais connecté en mode reset. Pour régler le problème, j’ai juste redémarré la piratebox et je me suis conn

      • dvalin33

        Bonjour,

        Dash, comment te connectes tu ? Telnet, ssh, autre ? J’ai eu le même problème mais je m’étais connecté en mode reset. Pour régler le problème, j’ai juste redémarré la piratebox et je me suis connecté en ssh et c’était bon.

    • Guillaume

      Visiblement tu as oublié le caractère « espace » entre « vi » et « /etc/… »
      Il faut taper : « vi /etc/config/firewall »

  • Guillaume

    Je vous conseil d’aller voir le contenu du fichier piratebox :
    après une connexion ssh faire :
    cat /etc/init.d/piratebox
    Vous y trouverez les commandes accessibles, dont « init » qui permet de Pirateboxiser une nouvelle clef USB !

    Vous pourrez ensuite aller voir /etc/piratebox.common :
    cat /etc/piratebox.common
    Vous y trouverez le détail. Bon il faut connaitre un peu le monde Unix ou le développement en général.

    Par contre je cherche les fichier qui génère l’HTML, pour y faire un truc un peu plus jolie. Mais je crains que ce soit dans les fichiers img de la clef usb…
    Si vous avez des infos je suis preneur.

  • Guillaume

    Bonjour à tous,
    Ma PirateBox est prête !
    Maintenant je vais essayer de faire un petit boitier propre.

    Comment ouvrir proprement le MR3020 sans le casser pour en extraire la carte ?
    Comment changer son antenne Wifi pour en mettre une extérieur ?

  • Guillaume

    Bonjour,
    Pour moi tout ok sur la première clef USB, mais si je tente d’utiliser une nouvelle clef USB cela ne marche pas. J’ai copié sur la nouvelle clef les fichiers qui étaient présents sur l’ancienne, ça ne fonctionne toujours pas. Pour le moment j’essaye sur une clef USB identique, mais je voudrais surtout utiliser une clef plus grosse (que j’ai aussi essayé sans succès).

    Une idée ? Y-a-t’il un script pour initialiser la nouvelle clef USB ?

    • dvalin

      Bonjour,

      J’ai eu le même problème, et le moins embêtant a été de toute recommencer. Je sais que c’est chiant mais ça a été le plus efficace dans mon cas.

    • Guillaume

      C’est écrit partout mais je ne l’avais pas bien lu : FAT32 !!!
      Visiblement, ma première clef est en FAT16, elle marche. Ma seconde clef en FAT16 ne marche pas. Je l’ai formaté en FAT32, elle marche. Je pense que la copie vers FAT16 ne prend pas les bons attributs de fichier.

  • Sylvain

    Bonjour

    Je suis bloqué a l’étape « opkg install piratebox* », il cherche la clé usb qu’il ne semble pas parvenir a trouver !!! J’ai branché differente clé : toujour la même chose :
    Please connect USB disk. If it is already plugged-in,
    wait for a few seconds, and if nothing happens, please
    reconnect the device. Keep in mind that your router’s
    ports may not be able to supply enough power to
    spin-up a USB HDD.
    ……………………………………………………………………………………

    • dvalin

      Bonjour,

      Tu dis avoir branché plusieurs clefs, après avoir le message ou avant ? Si c’est avant, débranche la et rebranche la. Ca a permis qu’il trouve la mienne (avant ça tournait en boucle).

      • Sylvain

        Bonjour

        J’ai essayé avant pendant, des dizaines de fois …
        l ne semble pas reconnaître ma clé.

        Je vois pas quoi faire…

  • Mer2022

    Salut!
    Moi j’ai aussi un petit probléme comme seb.
    Je suis sous linux donc je passe pas par Putty. Ma fenetre de cmd c’est fermé après le changement de passwd et depuis quand je tape : telnet 192.168.1.1 j’ai
    Trying 192.168.1.1…
    telnet: Unable to connect to remote host: Connection refused

    Impossible de continuer le tuto :-/ Que faire?
    Merci 🙂

    • dvalin

      Bonjour,

      Après la commande passwd, c’est normal que tu ne puisse plus te connecter via telnet. Il faut que tu te connecte en ssh : ssh root@192.168.1.1 La normalement, ça va te demander ton mot de passe.
      Si ça ne fonctionne pas, tente un ipconfig /all pour vérifier quelle ip est attribuée à ta machine (au cas ou).

  • Pingback: Ready, Set, Go … » PirateBox PartageBox TP-link MR3020()

  • trinus

    pardon pour le double post il me semblait que le premier n’était pas passé.

  • trinus

    Bonjour, j’ai suivi ce tuto à la lettre et la piratebox fonctionnait très bien à part qu’elle était lente.
    J’ai donc appliqué le tuto en modifiant le /etc/config/network mais depuis impossible de me connecter à la piratebox en wifi ou en ethernet et quand je dis impossible c’est à dire que mon PC ne ne se connecte pas du tout au réseau.

    DOnc si une âme charitable voulait bien m’aider.

    • trinus

      Bon j’essaye depuis plusieurs heures maintenant d’accéder à la pirtabox soit par telnet soit par ssh il n’y a rien à faire je ne peut pas y accéder mon PC n’arrive pas à communiquer avec la piratebox en ethernet (connexion impossible sous ubuntu comme sous windows).
      De temps à autre le telnet fonctionne mais il me demande un nom d’utilisateur et un mot de passe, j’ai essayer toutes les combinaisons à base de admin et de root avec mon mot de passe ou admin ou root. Rien à faire il me jette pendant 60 seconde. Ensuite impossible d’y accéder de nouveau.

      J’ai tenté plusieurs reset mais ça ne change rien. Je désespère.

      • dvalin33

        Bonsoir,

        J’ai eu le même problème que toi. Pour y remédier, j’ai suivis le commentaire de Jean-Pierre du 7avril.

        • trinus

          Merci beaucoup, j’ai réussi hier soir vers minuit et j’ai repris l’installation, tout fonctionne parfaitement maintenant. Petite question je peux changer l’adresse IP de la piratebox sans problème particulier ?

          • dvalin33

            Il n’y a pas de raison que ça ne fonctionne pas. Mais par curiosité, pourquoi veux tu changer l’adresse IP de la piratebox ?

          • Non tu ne peux changer l’adresse IP comme cela. Il me semble qu’il faut que l’adresse de ta PirateBox soit 192.168.1.1 pour que cela fonctionne en public.

          • trinus

            Simplement pour éviter d’avoir de faire un telnet ou un ssh sur ma livebox (192.168.1.1) quand ma piratebox est connectée sur mon réseau.

            Une autre question : je voudrais franciser l’interface quels sont les fichiers à éditer ?
            J’avoue ne pas mettre encore penché dessus.

  • Sebastien

    Bonjour,

    J’obtiens cette erreur, une idée ?

    root@OpenWrt:~# opkg install kmod-usb-ohci
    Multiple packages (kmod-usb-ohci and kmod-usb-ohci) providing same name marked HOLD or PREFER. Using latest.
    Upgrading kmod-usb-ohci on root from 3.2.9-1 to 3.2.13-1…
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/kmod-usb-ohci_3.2.13-1_ar71xx.ipk.
    Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
    Collected errors:
    * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-ohci:
    * kernel (= 3.2.13-1-be93f2269adcaf7eaeffd4cf0086e5dd) *
    * opkg_install_cmd: Cannot install package kmod-usb-ohci.

    • dvalin33

      J’obtiens la même erreur. Je pense qu’il y a eu une mise à jour, et qu’elle n’aime pas la piratebox.
      Si ça fait pareil que moi, tu vas avoir une erreur de dépendance si tu essaye d’installer la piratebox.

      Quelqu’un a réussit a passer outre cette erreur (arrivé ce week end) ?

      • Sebastien

        J’ai evoyé un mail au site Piratebox.c.la afin de leur poser la question.
        Je pensais avoir commis des erreurs mais je me rends finalement compte que je ne suis pas un cas isolé…

      • Dash

        Bon ben…up! Je rencontre le même problème. Quelqu’un a t-il solutionné la chose?

  • wild dagger

    Est ce quelqu’un a essayer de reproduire les étapes d’installation du paquet piratebox* en ligne de commande manuelle (je ne sais pas si c’est très francais ce que je dis) je souhaiterais installer pour mon simple usage perso un docuwiki sur un disque dur de 250 go

  • dvalin33

    Bonjour,

    Depuis que j’ai voulu passer sur la version avec le chat, je n’arrive plus sur la piratebox via un navigateur.
    Je peux y accéder via une session ssh ou telnet.
    J’ai tenté un rm -rf /overlay/*
    Puis j’ai réinstallé la piratebox comme marqué dans le tutoriel. Mais à priori le problème est lié à « opkg install kmod-usb-ohci » car ça me dit qu’il existe déjà une version plus récente sur le routeur.
    Je commence à être à cours d’idée. Quelqu’un pourrait m’aider ?

    Merci d’avance.

    • Salut,

      bien penser à remettre l’adresse 192.168.1.1 dans le fichier /etc/config/network.
      Sinon l’erreur sur la commande « opkg install kmod-usb-ohci » est normale et ne devrait pas poser de problème lors de l’installation.

      • dvalin33

        Pour /etc/config/network, j’ai ça actuellement :
        config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

        config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'

        Par contre, je ne sais pas si c’est lié, mais sur mon téléphone sous android (cyanogenmod 7 pour être plus précis), je ne peux plus me connecter. Il reste bloqué à la récupération de l’adresse ip.

        • Humm étonnant, tu es bien en mode WISP ?

          • dvalin33

            Oui, je suis en mode wisp.
            C’est bizarre car la connexion se fait sur le pc mais pas sur le mobile.
            Et pour le pc, via le navigateur j’ai une page 404. Par contre, ça fonctionne sans problème avec le ssh.

            Je ne sais plus trop quoi faire du coup.

          • Tu peux essayer un redémarrage de la PirateBox :

            /etc/init.d/piratebox restart

          • dvalin33

            Ta proposition de restart m’a permit de voir les erreurs suivantes :
            /etc/rc.common: line 82: /opt/piratebox/init.d/piratebox_router: not found
            mount: mounting /dev/sda1 on /mnt/usb failed: No such file or directory
            /etc/init.d/piratebox: ERROR: unable to mount USB storage

            Je comprends plus rien, j’ai viré l’overlay et reinstallé tout depuis le début.
            Comment pourrais je réparer ces erreurs ?

          • Tu avais raison, il y a un problème avec l’installation des packages de prise en charge USB. Je te propose de réinstaller les packages et de mettre ici les erreurs. Peut être que quelqu’un aura une idée.

          • dvalin33

            C’est bon, j’ai trouvé. Ca ne fonctionne pas avec la clef usb 32Go et ça fonctionne avec celle de 16Go. Je me demande s’il n’y a pas une limite de taille pour l’usb.

            Je vais retenter avec la clef usb 16Go avec le chat en plus.

          • Merci. Je vais l’ajouter dans l’article, ca pourra aider du monde.

  • Poil2Q

    Et hop la piratebox fonctionne 🙂

    Thank you le nhac, a mardi

  • vorphy

    RAahahaha j’ai les boules. j’ai voulu me faire une piratebox…et je me suis plante de modele..j’ai pris un mr3220 !!! dites moi que je peux qd meme monter le projet .. :S

    merci

  • Pingback: Reset du mr3020 | Le blog de Nicolas Hachet()

  • rikou

    Bonsoir , j’ai suivi toutes ses étapes , tous s’installe parfaitement, mais une fois que je me connecte au wifi généré par le routeur , le DHCP ne doit pas fonctionner car il attribue au pc une IP genre 169.254.23.63 et du coup impossible de se reconnecter au routeur pour changer la config car le ssh a 192.168.1.1 ne marche plus.

    De plus je n’ai pas trouvé comme faire un hard reset du routeur si vous aviez l’astuce pour tous recommencer de zéro.

    Merci bien.

    • Bonsoir,

      voir les commentaires précédent pour trouver l’adresse IP du routeur (ipconfig /all et prendre l’adresse la gateway). Ensuite, essayer de se connecter via putty ou telnet.
      Si ça ne fonctionne pas, le hardreset du mr3020 se fait en maintenant le bouton WPS pendant plus de 10s.

    • Jean-Pierre

      pour le hard reset, en détail :
      1) couper l’alimentation du routeur
      2) le régler sur wisp
      3) enfoncer la led wisp (côté prise Ethernet) puis alimenter le routeur en la mainenant enfoncé. la led va s’allumer puis s’éteindre pendant de longues secondes. relâcher quand elle se remet à clignoter.

    • Merci pour cette précision. Je me suis permis de faire un post avec cette astuce, ça permettra surement d’aider du monde : Reset du mr3020.

      • Jean-Pierre

        de rien. j’ai parlé de mémoire.

        il faut dire que j’ai pratiqué pas mal et galéré pour trouver comment faire.

        mais ça ne résout pas hélas le fait que je n’arrive pas à construire ma pirate box (voir mon long message antécédent). j’ai pourtant essayé avec deux MR3020. Je suis dégoûté.

        • Jean-Pierre

          comme dit ailleurs, j’avai oublié une étape pour le hard reset : alors je recommence et je cite ma source : http://www.disk91.com/2012/technology/networks/piratebox-creation-based-on-tp-link-mr3020/
          (et je confirme : ça marche aussi avec une piratebox dessus, je l’ai fait) :

          1) éteindre le MR3020 et mettre le sélecteur de mode sur AP
          2) cliquer sur le voyant WPS (au-dessus, juste à côté) et le maintenir enfoncé jusqu’à nouvel ordre
          3) allumer le MR3020. la diode WPS va s’allumer une fois et s’éteindre.
          4) peu après la diode WPS commence à clignoter lentement (2 fois par seconde) : mettez immédiatement le sélecteur de mode en 3G.
          5) la diode WPS clignote maintenant très vite. Relâchez la diode.
          6) accèddez au MR3020 par un telnet sur l’IP 192.168.1.1 si vous avez encore la ROM originale, par un ssh à son adresse IP (configurée par vos soins) si vous êtes déjà sous open-wrt.
          7) il faut monter /overlay pour y faire le ménage :

          mount_root

          8) supprimer /overlay (c’est le nettoyage de son contenu) :

          rm -rf /overlay/*

          9) Quittez votre session ssh ou telnet. Remettre le sélecteur de mode sur WISP. Éteindre et rallumer le MR3020.

          • Merci pour ta contribution, j’ai mis à jour l’article : Reset du mr3020.

          • Poil2Q

            Moi pour ma part , pour le hard reset, j’ai pas besoin de faire le foufou comme ca (avec un mr3020) :

            Juste rallumer le MR en mode WISP et attendre qu’il clignote lentement et la maintenir le bouton WSP jusqu’a ce que ca clignote vite. C’est tout (pas besoin de switcher de mode, de relacher-reappuyer comme j’ai pu voir, etc…)

          • Poil2Q

            A oui et pour reboot le MR3020 sans débrancher/rebrancher, juste taper : reboot -f

          • Humm je vais mettre les 2 méthodes alors. J’ai pas eu l’occasion de tester moi-même. J’ai juste eu à supprimer le contenu du répertoire /overlay/ pour changer de version de PB !

            Bonne soirée 😉

  • benoit

    bonjour. j’ai crée ma pirate box avec le routeur mr3020. j’ai reformaté un disque dur en fat32 et je l’ai adapté dessus. mon réseau pirate box fonctionne je peu envoyer et télécharger un fichier. Par contre je n’ai pas accès au chat malgré la version 0.2-5_all de piratebox et je ne peu plus accédé au dossier présent dans le disque dur dés qu’un telechargement est actif. Est ce normal ?

    • Bonsoir, il faut télécharger la version piratebox_0.3-2_all.ipk pour avoir le chat.

      • benoit

        merci et désolé. j’aurai pu relire plus précisément ton tuto. j’ai fait la mise a jour et la miracle mon routeur accepte plusieurs downloads et seeds simultané sans broncher. Par contre j’ai un message d’erreur pour le chat a partir d’un linux et de deux android. je n’ai pas essayer avec un windows. le message d’erreur c’est entre autre « la connexion a échoué » « page web non disponible » bref l’essentiel est la, permettre a plusieurs personne de naviguer sur le réseau en même temps.

        • benoit

          j’ai essayé de modifier le fichier /etc/config/network en suivant les conseils de votre fin de tuto pour voir si cela pouvais arranger mon problème de chat. Mais bon c’était une mauvaise idée. Mon routeur ne résout plus les adresse ip. Du coup. impossible de s’y connecter par ssh ou telnet. j’ai essayer la manip du reset sans succès. j’ai trouvé une autre manip qui consiste a mettre le routeur en ap avant le reboot et le wps enfoncé de switcher 10scd plus tard en 3G lors des premiers clignotement. Sans succès. Je pense que le hard reset ne fonctionne pas apres l’installation openwrt. la dernière fois que j’ai réussi c’était via ssh avec les commande suivante :
          mtd -r erase rootfs_data
          rm -r /overlay/*
          ce qui est drole c’est que branché a ma box il me donne accès au net.
          mais impossible de le retrouver même en scannant tout les port de la box.

          • benoit

            suite et fin de l’aventure.
            si comme moi vous avez briquer votre mr3020 et que le reset ne marche pas… et bien il reste la solution miracle !!

            mini tuto sous windows vista
            couper votre wifi
            passer en mode reset avec l’ethernet brancher
            (le plus simple est de simplement appuyer sur wps dés qu’elle commence a clignoter)

            panneau de configuration/centre reseau et partage/voir le statut/propriétés/
            sélectionner protocole internet version 4 puis propriétés
            utiliser l’ip suivante
            adresse ip : 192.168.1.2
            (on définit une ip a fixe a notre ordinateur)

            lancer un connexion en telnet avec putty :192.168.1.1
            et voila. pour pouvoir éditer les fichier root taper
            mount_root

            source : pirateboxfr.wordpress.com/problemes-et-resolutions/

            conclusion : le reset est un safe mode

            ps : n’oublier pas de remettre votre adresse ip en automatique.

          • Merci pour l’astuce !

  • Nico

    Bonjour,

    Je suis resté bloqué hier sur l’étape 4 « vi /etc/config/network ». Ca n’a pas voulu passer.

    Suite à un mail de Piratebox lille, j’ai trouvé votre blog. Je me suis connecté ce matin via Putty SSH sur la piratebox mais mon password (que j’ai réussi à changer) ne passe pas….

    sauf erreur de ma part le login est resté inchangé : admin.

    Je n’arrive qu’à me connecter en SSH avec l’adresse 192.168.1.1. Mais ca bloque avec mon password…j’ai essayé plusieurs fois. (notamment le mot de passe admin

    Quelle est la marche à suivre afin que je puisse avancer.

    Merci de votre aide.

    Nicolas

    • Bonjour,

      normalement le login est : root
      Et le mot de passe est celui défini lors de la connexion telnet.

    • Guillaume

      Attention, je ne sais pas comment cela se fait sur Windows (Putty ou autre) mais sur Linux il faut faire « ssh root@192.168.1.1″
      Sinon il prend ton login par défaut.

  • Jean-Pierre

    bonjour,

    Merci pour votre tutoriel.

    J’ai tout suivi mais… je n’ai pas de signal wifi en provenance de ma pirate box.

    # cat /etc/config/wireless

    config wifi-device ‘radio0’
    option type ‘mac80211′
    option channel ’11’
    option macaddr ’90:f6:52:20:b2:90′
    option hwmode ’11ng’
    option htmode ‘HT20’
    list ht_capab ‘SHORT-GI-20’
    list ht_capab ‘SHORT-GI-40’
    list ht_capab ‘RX-STBC1’
    list ht_capab ‘DSSS_CCK-40’
    option disabled ‘0’

    config wifi-iface
    option device ‘radio0’
    option network ‘lan’
    option mode ‘ap’
    option encryption ‘none’
    option ssid ‘Aardvark PirateBox – Share Freely’

    # cat /etc/config/network

    config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config interface ‘lan’
    option ifname ‘eth0’
    option type ‘bridge’
    option proto ‘static’
    option netmask ‘255.255.255.0’
    option gateway ‘192.168.1.254’
    option dns ‘8.8.8.8’
    option dns ‘8.8.4.4’
    option ipaddr ‘192.168.1.44’

    config interface ‘wan’
    option ifname ‘eth0.1’
    option proto ‘dhcp’
    option netmask ‘255.255.255.0’
    option gateway ‘192.168.1.254’
    option dns ‘8.8.8.8’
    option dns ‘8.8.4.4’

    # ifconfig

    br-lan Link encap:Ethernet HWaddr 90:F6:52:20:B2:90
    inet addr:192.168.1.44 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4223 errors:0 dropped:42 overruns:0 frame:0
    TX packets:889 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:273830 (267.4 KiB) TX bytes:110360 (107.7 KiB)

    eth0 Link encap:Ethernet HWaddr 90:F6:52:20:B2:90
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4264 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1055 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:339421 (331.4 KiB) TX bytes:174512 (170.4 KiB)
    Interrupt:4

    eth0.1 Link encap:Ethernet HWaddr 90:F6:52:20:B2:90
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:62868 (61.3 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:22 errors:0 dropped:0 overruns:0 frame:0
    TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1776 (1.7 KiB) TX bytes:1776 (1.7 KiB)

    Je n’ai aucun problème pour me connecter en filaire mais sans signal wifi, pas de piratebox. Merci d’avance de m’aider.

    • Bonjour,

      c’est étonnant que ça ne fonctionne pas. Peux-tu essayer en supprimant ces lignes dans le fichier /etc/config/network :

      config interface ‘wan’
      option ifname ‘eth0.1′
      option proto ‘dhcp’
      option netmask ’255.255.255.0′
      option gateway ’192.168.1.254′
      option dns ’8.8.8.8′
      option dns ’8.8.4.4′

      Quel est le contenu du fichier /etc/config/firewall ?

      • Jean-Pierre

        # cat /etc/config/firewall
        config defaults
        option syn_flood 1
        option input ACCEPT
        option output ACCEPT
        option forward ACCEPT
        # Uncomment this line to disable ipv6 rules
        # option disable_ipv6 1

        config zone
        option name lan
        option network ‘lan’
        option input ACCEPT
        option output ACCEPT
        option forward ACCEPT

        config zone
        option name wan
        option network ‘wan’
        option input ACCEPT
        option output ACCEPT
        option forward ACCEPT
        option masq 1
        option mtu_fix 1

        config forwarding
        option src lan
        option dest wan

        # We need to accept udp packets on port 68,
        # see https://dev.openwrt.org/ticket/4108
        config rule
        option name Allow-DHCP-Renew
        option src wan
        option proto udp
        option dest_port 68
        option target ACCEPT
        option family ipv4
        # Allow IPv4 ping
        config rule
        option name Allow-Ping
        option src wan
        option proto icmp
        option icmp_type echo-request
        option family ipv4
        option target ACCEPT

        # Allow DHCPv6 replies
        # see https://dev.openwrt.org/ticket/10381
        config rule
        option name Allow-DHCPv6
        option src wan
        option proto udp
        option src_ip fe80::/10
        option src_port 547
        option dest_ip fe80::/10
        option dest_port 546
        option family ipv6
        option target ACCEPT

        # Allow essential incoming IPv6 ICMP traffic
        config rule
        option name Allow-ICMPv6-Input
        option src wan
        option proto icmp
        list icmp_type echo-request
        list icmp_type echo-reply
        list icmp_type destination-unreachable
        list icmp_type packet-too-big
        list icmp_type time-exceeded
        list icmp_type bad-header
        list icmp_type unknown-header-type
        list icmp_type router-solicitation
        list icmp_type neighbour-solicitation
        option limit 1000/sec
        option family ipv6
        option target ACCEPT
        # Allow essential forwarded IPv6 ICMP traffic
        config rule
        option name Allow-ICMPv6-Forward
        option src wan
        option dest *
        option proto icmp
        list icmp_type echo-request
        list icmp_type echo-reply
        list icmp_type destination-unreachable
        list icmp_type packet-too-big
        list icmp_type time-exceeded
        list icmp_type bad-header
        list icmp_type unknown-header-type
        option limit 1000/sec
        option family ipv6
        option target ACCEPT

        # include a file with users custom iptables rules
        config include
        option path /etc/firewall.user

        ==========
        /etc/firewall.user ne contient aucune directive.

        # ifconfig
        br-lan Link encap:Ethernet HWaddr 90:F6:52:20:B2:90
        inet addr:192.168.1.44 Bcast:192.168.1.255 Mask:255.255.255.0
        UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
        RX packets:84 errors:0 dropped:1 overruns:0 frame:0
        TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0
        RX bytes:8383 (8.1 KiB) TX bytes:6194 (6.0 KiB)

        eth0 Link encap:Ethernet HWaddr 90:F6:52:20:B2:90
        UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
        RX packets:107 errors:0 dropped:0 overruns:0 frame:0
        TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000
        RX bytes:12156 (11.8 KiB) TX bytes:6326 (6.1 KiB)
        Interrupt:4

        lo Link encap:Local Loopback
        inet addr:127.0.0.1 Mask:255.0.0.0
        UP LOOPBACK RUNNING MTU:16436 Metric:1
        RX packets:0 errors:0 dropped:0 overruns:0 frame:0
        TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0
        RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

        Je ne vois toujours aucun wifi (mais là ça ne m’étonne pas, j’ai enlevé le réglage wif).

        # cat /etc/config/network

        config interface ‘loopback’
        option ifname ‘lo’
        option proto ‘static’
        option ipaddr ‘127.0.0.1’
        option netmask ‘255.0.0.0’

        config interface ‘lan’
        option ifname ‘eth0’
        option type ‘bridge’
        option proto ‘static’
        option netmask ‘255.255.255.0’
        option gateway ‘192.168.1.254’
        option dns ‘8.8.8.8’
        option dns ‘8.8.4.4’
        option ipaddr ‘192.168.1.44’

  • jbz0

    Après plusieurs, je n’arrives plus a me connecté avec putty a partir du moment ou je le branche sur ma box. Des que je retire le routeur de ma box et que je la redémarre je peux me reconnecté sans soucis !
    Donc la question qui tue: Est il possible d’installer le support USB d’une autre méthode?

    • Humm probablement mais ça va être plus compliqué…
      Peux-tu indiquer l’adresse IP de ton routeur. Pour cela, met le résultat de cette commande :

      cmd.exe > ipconfig /all

  • seb

    ok j ai compris comment enregistrer les parametres j oubliais les 2 points : (
    Par contre toujours impossible de me connecter via putty quand ma box est branchée

    • Oui les « : » sont importants, c’est ce qui permet d’accéder au menu de vi.

      Pour te connecter via Putty quand ta box est branchée, il faut que l’adresse IP du fichier /etc/config/network soit différente de l’adresse de ta box. Il faut donc remettre l’adresse IP arbitraire. Comme ceci :

      config interface ‘loopback’
      option ifname ‘lo’
      option proto ‘static’
      option ipaddr ’127.0.0.1′
      option netmask ’255.0.0.0′
      config interface ‘lan’
      option ifname ‘eth0′
      option type ‘bridge’
      option proto ‘static’
      option ipaddr ‘192.168.1.55‘ {IP arbitraire}
      option netmask ’255.255.255.0′
      option gateway ‘192.168.1.254‘ {IP de ta box}
      list dns ‘192.168.1.254‘ {IP de ta box}
      list dns ’8.8.8.8′

      Ensuite il faut redémarrer le MR3020, le connecter via câble réseau et tenter la connexion Putty.

      • seb

        Bonsoir juste pour vous dire merci pour vos conseils j ai fini par réussir mon installation
        Bonne continuation

  • jbz0

    Bonjour,
    Je suis egalement bloqué a l’etape 4, je n’arrive pas a me connecté ni avec 192.168.1.1 ni avec l’adresse spécifié…, que faire?
    Merci d’avance.

    • Bonsoir,

      quelle est l’erreur affichée ?
      Si l’adresse votre box est 192.168.0.XX, essayez l’adresse ci-dessous :
      192.168.0.1

      • jbz0

        Merci pour la réponse rapide.

        Sinon, j’ai juste des times out, même avec votre adresse !
        Le plus étrange, c’est que j’arrive a me connecté au routeur vu que j’ai internet par celui ci !

        Pour info, je suis chez néo (FAI des etudiants :(), et je ne dispose que d’un modem avec 1 seul port RJ45 et je n’ai pas acces a la page admin !

  • seb

    des que j essai de me reconnecter telnet 192.168.1.1 ou 192.168.1.64
    (addresse que j ai specifie) , j ai un message d erreur
    « impossible d ouvrir une connexion a l hote, sur le port 23 : echec de la connexion  »
    Un reset me permettrait il de recommencer depuis le debut

    • Avant de faire un reset, je te conseille de tester la connexion SSH. Télécharge Putty et tente une connexion sur les 2 IPs que tu as marquées.

      Tu peux également faire un

      telnet 192.168.1.1 22

      .

  • seb

    Salut
    Voila j ai malencontreusement fermer la fenetre cmd a la fin de l etape 4
    « 4. Configurer le réseau du MR3020 » et depuis impossible de rejoindre l interface du routeur .Comment puis je proceder , un reset ?
    Merci

    • Salut Seb,

      normalement, si tu n’as pas rebooté le routeur, tu peux de nouveau t’y connecter via telnet (telnet 192.168.1.1). Si ce n’est pas le cas, essaie de te connecter en SSH via Putty (Installation de l’application PirateBox, étape 1) aux deux adresses :
      – 192.168.1.1
      – l’adresse que tu as spécifié à l’étape 4

      Bon courage.

      • seb

        Je peux me connecter via putty a l addresse 192.168.1.1 mais que lorsque ma neufbox est debranchée (normale je pense vu que ma neuf a aussi l ip 192.168.1.1)
        lorsque je tape  » vi /etc/config/network  »
        je modifie les parametres comme tu le dis mais je n arrive pas a sauvegarder [Echap]:wq[Entrée] .J ai un message
        q is not implemented
        Dsl de faire mon boulet mais pour un noob c est vraiment pas evident
        Merci

        • Oui il en faut pas oublier les « : » (deux points) dans la commande :

          [Esc]:wq[Entrée]

  • Pingback: PirateBox : le partage de fichiers via réseau Wifi local » Le blog de Nicolas Hachet()