Excel : compter les valeurs distinctes d’une colonne

09 Jan 2013 3

Une fois n’est pas coutume, voici une petite astuce Excel permettant de compter les valeurs distinctes d’une colonne dans une feuille de calculs XLS.

Formule pour compter les valeurs uniques

Disons que l’on souhaite compter le nombre de lignes ayant des valeurs uniques (ce qui revient à faire un SELECT COUNT(DISTINCT()) en MySQL) sur la colonne A allant de la ligne 20 à la ligne 200. La formule Excel doit ressembler à celle-ci :

[text]=SOMMEPROD(1/NB.SI(A20:A200;A20:A200))[/text]

Formule pour compter toutes les lignes d’une plage

Pour mémoire, voici comment on compte toutes les lignes d’une colonne :

[text]=NBVAL(A20:A200)[/text]

Il y a peut être d’autres moyens pour réaliser ceci : les commentaires sont ouverts.